summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-08-13 02:19:39 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2020-10-11 11:43:06 -0400
commit70b1af0640ef31b619bfc3f2c95712aae4ce7409 (patch)
tree2e298515e172f08850f75660346fe3930597e9db /configure.ac
parent1bf4555800618b24dbe32649e33bb5bbe2bab991 (diff)
downloadlighttpd-git-70b1af0640ef31b619bfc3f2c95712aae4ce7409.tar.gz
[core] link in ls-hpack (EXPERIMENTAL)
LiteSpeed ls-hpack v2.2.1 XXX: might be better to include this as a git submodule but minor code changes were made here for portability: - C99 flexible array members defined as a[] instead of a[0]) - pedantic compiler warnings (excess ';' and missing declarations) - deletion of large tables from ls-hpack/huff-tables.h (code size)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c198d44..df0d4c84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1588,6 +1588,8 @@ if test "$extrawarnings" = true || test "$extrawarnings" = error; then
fi
fi
+AS_VAR_APPEND([CFLAGS], [" -DLS_HPACK_USE_LARGE_TABLES=0 -DXXH_HEADER_NAME=\\\"ls-hpack/deps/xxhash/xxhash.h\\\""])
+
dnl build version-id
LIGHTTPD_VERSION_ID=m4_format([0x%x%02x%02x], m4_unquote(m4_split(AC_PACKAGE_VERSION, [\.])))
AC_DEFINE_UNQUOTED([LIGHTTPD_VERSION_ID], [$LIGHTTPD_VERSION_ID], [lighttpd-version-id])