summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-12-06 06:16:02 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-03 02:28:08 -0500
commit750414d3bb6f13c119220e56d0c8123e665dffc5 (patch)
treef923eeb914ce6f7f7e935d4b62963dfcd1ebec9c /configure.ac
parent86c2d3093686c4f945086c90af9b8a7900925b6b (diff)
downloadlighttpd-git-750414d3bb6f13c119220e56d0c8123e665dffc5.tar.gz
[build] default --with-pcre2 unless --with-pcre
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 14 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 1cfdf51a..1db5f3ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -907,17 +907,27 @@ if test "x$use_nss" = "xyes"; then
fi
+dnl pcre support
+AC_MSG_NOTICE([----------------------------------------])
+AC_MSG_CHECKING([for perl regular expressions support])
+AC_ARG_WITH([pcre],
+ [AS_HELP_STRING([--with-pcre], [Enable pcre support (default yes)])],
+ [WITH_PCRE=$withval],
+ [WITH_PCRE=no]
+)
+AC_MSG_RESULT([$WITH_PCRE])
+
dnl pcre2 support
AC_MSG_NOTICE([----------------------------------------])
AC_MSG_CHECKING([for perl regular expressions support])
AC_ARG_WITH([pcre2],
[AS_HELP_STRING([--with-pcre2], [Enable pcre2 support (default no)])],
[WITH_PCRE2=$withval],
- [WITH_PCRE2=no]
+ [WITH_PCRE2=yes]
)
AC_MSG_RESULT([$WITH_PCRE2])
-if test "$WITH_PCRE2" != no; then
+if test "$WITH_PCRE2" != no && test "$WITH_PCRE" = "no"; then
if test "$WITH_PCRE2" != yes; then
PCRE_LIB="-L$WITH_PCRE2/lib -lpcre2-8"
CPPFLAGS="$CPPFLAGS -I$WITH_PCRE/include"
@@ -943,17 +953,7 @@ if test "$WITH_PCRE2" != no; then
AC_SUBST([PCRE_LIB])
fi
-dnl pcre support
-AC_MSG_NOTICE([----------------------------------------])
-AC_MSG_CHECKING([for perl regular expressions support])
-AC_ARG_WITH([pcre],
- [AS_HELP_STRING([--with-pcre], [Enable pcre support (default yes)])],
- [WITH_PCRE=$withval],
- [WITH_PCRE=yes]
-)
-AC_MSG_RESULT([$WITH_PCRE])
-
-if test "$WITH_PCRE" != no && test "$WITH_PCRE2" = "no"; then
+if test "$WITH_PCRE" != no; then
if test "$WITH_PCRE" != yes; then
PCRE_LIB="-L$WITH_PCRE/lib -lpcre"
CPPFLAGS="$CPPFLAGS -I$WITH_PCRE/include"
@@ -974,6 +974,7 @@ if test "$WITH_PCRE" != no && test "$WITH_PCRE2" = "no"; then
AC_SUBST([PCRE_LIB])
fi
+
dnl zlib
AC_MSG_NOTICE([----------------------------------------])
AC_MSG_CHECKING([for zlib support])