summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-11-03 00:48:38 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2020-11-04 03:53:15 -0500
commit7ce8b22cb2e9cda31b257e81e9b882cd76fd9f3c (patch)
tree703a95c60e77948f3144ec7f9ae598d992f2edd6 /configure.ac
parent5c7173026f918e1d09a317db6b574c35ce6d568e (diff)
downloadlighttpd-git-7ce8b22cb2e9cda31b257e81e9b882cd76fd9f3c.tar.gz
[build] detect inotify header <sys/inotify.h>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 246692a9..97ced9ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,7 @@ AC_CHECK_HEADERS([\
sys/epoll.h \
sys/event.h \
sys/filio.h \
+ sys/inotify.h \
sys/loadavg.h \
sys/mman.h \
sys/poll.h \
@@ -1036,6 +1037,10 @@ AC_ARG_WITH([fam],
)
AC_MSG_RESULT([$WITH_FAM])
+if test "$HAVE_SYS_NOTIFY_H" != no; then
+ WITH_FAM=no
+fi
+
if test "$WITH_FAM" != no; then
if test "$WITH_FAM" != yes; then
FAM_LIBS="-L$WITH_FAM -lfam"