summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-07-09 00:40:46 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2021-09-04 08:08:26 -0400
commit82c199db3f112cf9c12e29931419690e85d7947a (patch)
tree9fcacd9346f0599325beabe399bfeb8c2a9c1e86 /configure.ac
parent3ce554e18cc071a8a69142507cae979b99037513 (diff)
downloadlighttpd-git-82c199db3f112cf9c12e29931419690e85d7947a.tar.gz
[autoconf] add AC_SYS_LARGEFILE for lfs
add AC_SYS_LARGEFILE for large file support (in addition to manually defining macros for large file support on different platforms; bootstrap-and-suspenders)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74eee80d..5787480e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1554,6 +1554,7 @@ AC_ARG_ENABLE([lfs],
AC_MSG_RESULT([$ENABLE_LFS])
if test "$ENABLE_LFS" = yes; then
CPPFLAGS="${CPPFLAGS} -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES"
+ AC_SYS_LARGEFILE
fi
dnl check if sendfile works