summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-10-13 08:26:05 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2020-10-19 21:40:14 -0400
commita46f519eb2e8355221eeeede1b36b7aff0e4a4eb (patch)
tree09aebe3f61f407d703fe8696baa7c731d1baaed2 /configure.ac
parentbdb5fb26a8ba433e853a5110a6cbbe9721d94ec1 (diff)
downloadlighttpd-git-a46f519eb2e8355221eeeede1b36b7aff0e4a4eb.tar.gz
[multiple] use NSS crypto if no other crypto avail
use NSS crypto if no other crypto avail, but NSS crypto is available "NSS crypto support" is not included in tests/LightyTest.pm:has_crypto() due to NSS libraries (freebl3) lacking public export for HMAC funcs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 81e5ffd4..095a745d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -883,10 +883,15 @@ if test "x$use_nss" = "xyes"; then
NSS_LIBS="-L$WITH_NSS/lib"
else
PKG_CHECK_MODULES([NSS],[nss])
+ CPPFLAGS="$CPPFLAGS -I/usr/include/nspr4"
fi
AC_DEFINE([HAVE_NSS3_NSS_H], [1], [nss3/nss.h])
AC_SUBST([NSS_CFLAGS])
AC_SUBST([NSS_LIBS])
+ if test "x$CRYPTO_LIB" = "x"; then
+ CRYPTO_LIB="-lnss3"
+ AC_SUBST([CRYPTO_LIB])
+ fi
fi