summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-10-03 11:01:40 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2021-10-03 11:01:40 -0400
commitb17c37c5e58a4ebb3b0dcc6c7643e447e68d4374 (patch)
treebfbc6454dac63ca11410ddea77ac63c017d8f402 /configure.ac
parent94edf7e844d4c8a957fdc4ceeaf09bfbde8e0968 (diff)
downloadlighttpd-git-b17c37c5e58a4ebb3b0dcc6c7643e447e68d4374.tar.gz
[mod_openssl] boringssl compat
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d90c0598..8989d724 100644
--- a/configure.ac
+++ b/configure.ac
@@ -682,7 +682,7 @@ if test "$WITH_OPENSSL" != no; then
AC_CHECK_HEADERS([openssl/ssl.h], [], [
AC_MSG_ERROR([openssl headers not found. install them or build without --with-openssl])
])
- AC_CHECK_LIB([crypto], [BIO_f_base64],
+ AC_CHECK_LIB([crypto], [RAND_bytes],
[CRYPTO_LIB="-lcrypto"],
[AC_MSG_ERROR([openssl crypto library not found. install it or build without --with-openssl])]
)