summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-10-27 03:47:35 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2020-10-27 03:47:35 -0400
commitdb7252ec135693af5b8010a5326fa26a621784e8 (patch)
tree014ba5f4da76458a4ca9594449737fbd1eefa130 /configure.ac
parent1f1b3bcc558cf688f6b666716101dbf3750a156f (diff)
downloadlighttpd-git-db7252ec135693af5b8010a5326fa26a621784e8.tar.gz
[build] fix lib paths for GnuTLS, NSSlighttpd-1.4.56-rc2
(thx dirk)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1a6918c1..8a0fd423 100644
--- a/configure.ac
+++ b/configure.ac
@@ -850,7 +850,7 @@ GNUTLS_LIBS=
if test "x$use_gnutls" = "xyes"; then
if test "$WITH_GNUTLS" != "yes"; then
GNUTLS_CFLAGS="-I$WITH_GNUTLS/include"
- GNUTLS_LIBS="-L$WITH_GNUTLS/lib"
+ GNUTLS_LIBS="-L$WITH_GNUTLS/lib -lgnutls"
else
dnl oldest GnuTLS supported release is 3.3.x at time this is being written
PKG_CHECK_MODULES([GNUTLS], [gnutls >= 3.3.0])
@@ -887,7 +887,7 @@ NSS_LIBS=
if test "x$use_nss" = "xyes"; then
if test "$WITH_NSS" != "yes"; then
NSS_CFLAGS="-I$WITH_NSS/include"
- NSS_LIBS="-L$WITH_NSS/lib"
+ NSS_LIBS="-L$WITH_NSS/lib -lnss3"
else
PKG_CHECK_MODULES([NSS],[nss])
CPPFLAGS="$CPPFLAGS -I/usr/include/nspr4"