summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-06-28 23:43:16 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2020-07-08 22:51:32 -0400
commite00deb5578d586ff3b535f96ca684f233c0e7681 (patch)
tree476ce5bf65d5a1f06b266c22705eefb17b09a30d /configure.ac
parent8a1ddce0c2422efb100d6a177dd06e30909913ab (diff)
downloadlighttpd-git-e00deb5578d586ff3b535f96ca684f233c0e7681.tar.gz
[mod_nss] NSS option for TLS (fixes #1218)
(experimental) WARNING: EXPERIMENTAL code sketch; mod_nss is INCOMPLETE and UNTESTED mod_nss supports most ssl.* config options supported by mod_openssl x-ref: "alternate ssl backend" https://redmine.lighttpd.net/issues/1218
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b18831aa..3faf4d0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -852,6 +852,38 @@ if test "x$use_gnutls" = "xyes"; then
fi
fi
+dnl Check for NSS
+AC_MSG_NOTICE([----------------------------------------])
+AC_MSG_CHECKING([for NSS])
+AC_ARG_WITH([nss],
+ AC_HELP_STRING([--with-nss@<:@=DIR@:>@],[Include NSS support. DIR points to the installation root. (default no)]),
+ [WITH_NSS=$withval],
+ [WITH_NSS=no]
+)
+
+if test "$WITH_NSS" != "no"; then
+ use_nss=yes
+else
+ use_nss=no
+fi
+AC_MSG_RESULT([$use_nss])
+AM_CONDITIONAL(BUILD_WITH_NSS, test ! $WITH_NSS = no)
+
+NSS_CFLAGS=
+NSS_LIBS=
+
+if test "x$use_nss" = "xyes"; then
+ if test "$WITH_NSS" != "yes"; then
+ NSS_CFLAGS="-I$WITH_NSS/include"
+ NSS_LIBS="-L$WITH_NSS/lib"
+ else
+ PKG_CHECK_MODULES([NSS],[nss])
+ fi
+ AC_DEFINE([HAVE_NSS3_NSS_H], [1], [nss3/nss.h])
+ AC_SUBST([NSS_CFLAGS])
+ AC_SUBST([NSS_LIBS])
+fi
+
dnl pcre support
AC_MSG_NOTICE([----------------------------------------])
@@ -1652,6 +1684,9 @@ lighty_track_feature "network-mbedtls" "mod_mbedtls" \
lighty_track_feature "network-gnutls" "mod_gnutls" \
'test "$WITH_GNUTLS" != no'
+lighty_track_feature "network-nss" "mod_nss" \
+ 'test "$WITH_NSS" != no'
+
lighty_track_feature "auth-crypt" "" \
'test "$found_crypt" != no'