summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-01-08 13:33:02 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-08 13:33:02 -0500
commitf95ca5ef3b2890abfac73e7a0d59695442b1e37a (patch)
tree8c24a52ddc79c8860c0f7ef37f18b4f94e64d47d /configure.ac
parent8c62a890e23f5853b1a562b03fe3e1bccc6e7664 (diff)
downloadlighttpd-git-f95ca5ef3b2890abfac73e7a0d59695442b1e37a.tar.gz
[build] use -fstack-protector-strong w/ extra warn
use -fstack-protector-strong if configured with --enable-extra-warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a05b8115..31e92d9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1623,6 +1623,7 @@ AC_ARG_ENABLE([extra-warnings],
if test "$extrawarnings" = true || test "$extrawarnings" = error; then
TRY_CFLAGS([-g -O2 -g2 -Wall -Wmissing-declarations -Wcast-align -Wsign-compare -Wnested-externs -Wpointer-arith -D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security])
+ TRY_CFLAGS([-fstack-protector-strong])
case "$host_os" in
*darwin* ) ;;
* ) TRY_LDFLAGS([-Wl,--as-needed]) ;;