summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-05-24 22:02:50 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2021-08-27 02:16:53 -0400
commitfbefda35240856630b0b388304ba5713af34ff54 (patch)
tree27df5815eed8796362f542480c92eb82f3163039 /configure.ac
parentbb1d35dc17671bc308e25651b4f5fa0c3008cc69 (diff)
downloadlighttpd-git-fbefda35240856630b0b388304ba5713af34ff54.tar.gz
[build] MacOS linker compat
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7b429ca8..2530fdfc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1665,10 +1665,16 @@ AC_ARG_ENABLE([extra-warnings],
if test "$extrawarnings" = true || test "$extrawarnings" = error; then
TRY_CFLAGS([-g -O2 -g2 -Wall -Wmissing-declarations -Wcast-align -Wsign-compare -Wnested-externs -Wpointer-arith -D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security])
- TRY_LDFLAGS([-Wl,--as-needed])
+ case "$host_os" in
+ *darwin* ) ;;
+ * ) TRY_LDFLAGS([-Wl,--as-needed]) ;;
+ esac
if test "$extrawarnings" = error; then
AS_VAR_APPEND([CFLAGS], [" -Werror"])
- AS_VAR_APPEND([LDFLAGS], [" -Wl,--fatal-warnings"])
+ case "$host_os" in
+ *darwin* ) ;;
+ * ) AS_VAR_APPEND([LDFLAGS], [" -Wl,--fatal-warnings"]) ;;
+ esac
fi
fi