summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2017-11-05 18:50:25 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2017-11-05 18:50:25 -0500
commitfdc4c324c4df38e04c858a2f8c2081c872c50ba5 (patch)
treefbfb0ebd26a0431c131a000358bf08096b4b94dc /configure.ac
parent5a5ce3dc75286d5e3aa105c11d66f0063c48fe51 (diff)
downloadlighttpd-git-fdc4c324c4df38e04c858a2f8c2081c872c50ba5.tar.gz
[mod_authn_ldap] replace use of deprecated funcs
[mod_authn_ldap,mod_vhostdb_ldap] replace use of deprecated funcs remove -DLDAP_DEPRECATED
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index de4ce8e5..1f616d13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,13 +362,12 @@ AC_ARG_WITH([ldap],
AC_MSG_RESULT([$WITH_LDAP])
if test "$WITH_LDAP" != no; then
- AC_CHECK_LIB([ldap], [ldap_bind],
+ AC_CHECK_LIB([ldap], [ldap_sasl_bind_s],
[AC_CHECK_HEADERS([ldap.h],
[
LDAP_LIB=-lldap
AC_DEFINE([HAVE_LIBLDAP], [1], [libldap])
AC_DEFINE([HAVE_LDAP_H], [1])
- AC_DEFINE([LDAP_DEPRECATED], [1], [Using deprecated ldap api])
],
[AC_MSG_ERROR([ldap headers not found, install them or build without --with-ldap])]
)],