summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Bühler <stbuehler@web.de>2017-10-21 16:00:10 +0200
committerGlenn Strauss <gstrauss@gluelogic.com>2017-10-28 22:54:45 -0400
commit16c4530e614b6edbfb840e0aae320908079e38f7 (patch)
treefd3cdea4e3642115322a343008d1a78a4654cfaa /meson.build
parent02ad06b080148478f5748131849f5ee1273bfb88 (diff)
downloadlighttpd-git-16c4530e614b6edbfb840e0aae320908079e38f7.tar.gz
[meson] new build system
Needed to extend lemon to take an output path parameter.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 00000000..19a9f381
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,19 @@
+project('lighttpd', 'c', version: '1.4.48', default_options : ['c_std=c11'])
+
+subdir('src')
+subdir('tests')
+
+# setup (in build directory):
+# $ meson $src
+
+# compile:
+# $ ninja
+
+# full build:
+# $ meson configure -D build_extra_warnings=true -D with_bzip=true -D with_dbi=true -D with_fam=true -D with_gdbm=true -D with_geoip=true -D with_krb5=true -D with_ldap=true -D with_libev=true -D with_libunwind=true -D with_lua=true -D with_memcached=true -D with_mysql=true -D with_openssl=true -D with_pcre=true -D with_pgsql=true -D with_webdav_locks=true -D with_webdav_props=true -D with_xattr=true -D with_zlib=true
+
+# optimized build:
+# $ meson configure -D b_lto=true -D buildtype=debugoptimized
+
+# monolitic build (contains all plugins):
+# $ meson configure -D build_static=true