summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-02-15 19:32:37 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2023-05-03 23:11:34 -0400
commit05b3d156c31af25bc08a6a7117899e39e337b48f (patch)
treed977efa7a2d7be78eb03f1972bf1fcee779809e0 /src/CMakeLists.txt
parent3f4e686cdcb2932057b4108c702bbb4aa4018846 (diff)
downloadlighttpd-git-05b3d156c31af25bc08a6a7117899e39e337b48f.tar.gz
[core] _WIN32 custom fs funcs on UTF-8 paths
open(), stat(), mkdir() on UTF-8 paths lighttpd provides large file support and 64-bit time, so provide override to use _stati64() (and _wstati64()) Additionally, provide custom function to support stat on UTF-8 path, which must first be converted to wide-char and _wstati64(), since _stati64() is naive and does not properly support UTF-8.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b8cce9c9..d525f240 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -847,7 +847,7 @@ set(COMMON_SRC
ck.c
)
if(WIN32)
- set(COMMON_SRC ${COMMON_SRC} fdevent_win32.c)
+ set(COMMON_SRC ${COMMON_SRC} fdevent_win32.c fs_win32.c)
endif()
set(BUILTIN_MODS