summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-01-12 23:23:38 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2023-01-13 00:37:38 -0500
commit2351466d61ea1011083f2b57689792d2e09c1121 (patch)
treeb1e94ebcfe728fbca940178a6d5241202076cfec /src/CMakeLists.txt
parentb3c91e7477c50d212cf72be6e41f71b0e6505484 (diff)
downloadlighttpd-git-2351466d61ea1011083f2b57689792d2e09c1121.tar.gz
[cmake] SERVER_SRC variable
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f08fad77..be1085fe 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -882,7 +882,7 @@ add_executable(lighttpd-angel lighttpd-angel.c)
set(L_INSTALL_TARGETS ${L_INSTALL_TARGETS} lighttpd-angel)
add_target_properties(lighttpd-angel COMPILE_FLAGS "-DSBIN_DIR=\\\\\"${CMAKE_INSTALL_FULL_SBINDIR}\\\\\"")
-add_executable(lighttpd
+set(SERVER_SRC
server.c
response.c
connections.c
@@ -899,9 +899,9 @@ add_executable(lighttpd
data_config.c
configfile.c
configparser.c
- ${COMMON_SRC}
- ${BUILTIN_MODS}
)
+
+add_executable(lighttpd ${SERVER_SRC} ${COMMON_SRC} ${BUILTIN_MODS})
set(L_INSTALL_TARGETS ${L_INSTALL_TARGETS} lighttpd)
add_and_install_library(mod_access mod_access.c)