summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-01-04 21:13:46 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2023-01-04 21:13:46 -0500
commit2881812b735693f48025c6a5ac9d769c555fdcd6 (patch)
tree7fbbeae63f7220d223e80e1c163a654204119204 /src/CMakeLists.txt
parentcc0bb8aa00c321d86a75a7f8138b4f783bac1bf3 (diff)
downloadlighttpd-git-2881812b735693f48025c6a5ac9d769c555fdcd6.tar.gz
[cmake] do not link with fam if inotify or kqueue
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 43e36a77..f08fad77 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -771,7 +771,7 @@ else()
unset(HAVE_LUA_H)
endif()
-if(WITH_FAM AND NOT HAVE_SYS_INOTIFY_H)
+if(WITH_FAM AND NOT HAVE_SYS_INOTIFY_H AND NOT HAVE_KQUEUE)
check_include_files(fam.h HAVE_FAM_H)
check_library_exists(fam FAMOpen2 "" HAVE_LIBFAM)
if(HAVE_LIBFAM)