summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-12-03 00:20:23 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-12-03 00:20:23 -0500
commit33fd0db9e5acb8a7675400d032fff178de0a7c6e (patch)
tree57f1e1f5bb8887417a8a4251b5aec78dba35afea /src/CMakeLists.txt
parent3625f99bd2d65f194bde56567c0765db730c5633 (diff)
downloadlighttpd-git-33fd0db9e5acb8a7675400d032fff178de0a7c6e.tar.gz
[core] remove libev fdevent option (ignore)
lighttpd directly uses native OS event handlers
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1cdda123..1d249ae1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -88,11 +88,6 @@ else()
set(CMAKE_SHARED_LIBRARY_PREFIX "")
endif()
-if(WITH_LIBEV)
- find_package(LibEV REQUIRED)
- set(HAVE_LIBEV 1)
-endif()
-
if(WITH_LIBUNWIND)
pkg_check_modules(LIBUNWIND REQUIRED libunwind)
set(HAVE_LIBUNWIND 1)
@@ -1175,13 +1170,6 @@ if(HAVE_LIBSSL3 AND HAVE_LIBSMIME3 AND HAVE_LIBNSS3 AND HAVE_LIBNSSUTIL3)
target_link_libraries(mod_nss ${L_MOD_NSS})
endif()
-if(WITH_LIBEV)
- target_link_libraries(lighttpd ${LIBEV_LDFLAGS})
- add_target_properties(lighttpd COMPILE_FLAGS ${LIBEV_CFLAGS})
- target_link_libraries(test_mod ${LIBEV_LDFLAGS})
- add_target_properties(test_mod COMPILE_FLAGS ${LIBEV_CFLAGS})
-endif()
-
if(WITH_LIBUNWIND)
target_link_libraries(lighttpd ${LIBUNWIND_LDFLAGS})
add_target_properties(lighttpd COMPILE_FLAGS ${LIBUNWIND_CFLAGS})