summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-05-08 01:01:26 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2023-05-08 01:01:26 -0400
commit61dc9affb72f12a309e5ebb851da5724ac4c561a (patch)
tree7ae913fcf957f094177b81b135c63217b6afa951 /src/CMakeLists.txt
parent9f0b30b5cafbeb8409a1ebc285b3de3142d5df88 (diff)
downloadlighttpd-git-61dc9affb72f12a309e5ebb851da5724ac4c561a.tar.gz
[core] posix_spawn_file_actions_addclosefrom_np()
use posix_spawn_file_actions_addclosefrom_np() where available
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ea7ba2f9..92642d08 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -212,6 +212,7 @@ endif()
check_include_files(spawn.h HAVE_SPAWN_H)
if(HAVE_SPAWN_H)
check_function_exists(posix_spawn HAVE_POSIX_SPAWN)
+check_function_exists(posix_spawn_file_actions_addclosefrom_np HAVE_POSIX_SPAWN_FILE_ACTIONS_ADDCLOSEFROM_NP)
check_function_exists(posix_spawn_file_actions_addfchdir_np HAVE_POSIX_SPAWN_FILE_ACTIONS_ADDFCHDIR_NP)
endif()