summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2022-09-27 09:20:34 +0200
committerGlenn Strauss <gstrauss@gluelogic.com>2022-11-23 08:44:48 -0500
commit780023e89b19ef41ee388c73f67dfcf0d523bd20 (patch)
tree9bcbc9549c3d98088c207329ca5120ed3cec16e2 /src/CMakeLists.txt
parent5ef8657bd1514cf395fb364a48e720091353659b (diff)
downloadlighttpd-git-780023e89b19ef41ee388c73f67dfcf0d523bd20.tar.gz
[cmake] remove path hints where CMake searches by default
github: closes #121
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 3 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dd51b629..46009468 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -300,7 +300,7 @@ macro(XCONFIG _package _link_FLAGS _cflags)
set(${_link_FLAGS})
set(${_cflags})
- find_program(${_package}CONFIG_EXECUTABLE NAMES ${_package} PATHS /usr/local/bin )
+ find_program(${_package}CONFIG_EXECUTABLE NAMES ${_package})
# if pkg-config has been found
if(${_package}CONFIG_EXECUTABLE)
@@ -548,15 +548,11 @@ if(WITH_PCRE2)
check_library_exists(pcre2-8 pcre_match "" HAVE_PCRE)
set(PCRE_LDFLAGS -lpcre2-8)
else()
- find_path(PCRE_INCLUDE_DIR pcre2.h
- /usr/local/include
- /usr/include
- )
+ find_path(PCRE_INCLUDE_DIR pcre2.h)
set(PCRE_NAMES pcre2-8)
find_library(PCRE_LIBRARY
NAMES ${PCRE_NAMES}
- PATHS /usr/lib /usr/local/lib
)
if(PCRE_INCLUDE_DIR AND PCRE_LIBRARY)
@@ -599,15 +595,11 @@ elseif(WITH_PCRE)
check_library_exists(pcre pcre_exec "" HAVE_PCRE)
set(PCRE_LDFLAGS -lpcre)
else()
- find_path(PCRE_INCLUDE_DIR pcre.h
- /usr/local/include
- /usr/include
- )
+ find_path(PCRE_INCLUDE_DIR pcre.h)
set(PCRE_NAMES pcre)
find_library(PCRE_LIBRARY
NAMES ${PCRE_NAMES}
- PATHS /usr/lib /usr/local/lib
)
if(PCRE_INCLUDE_DIR AND PCRE_LIBRARY)