summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-02-18 03:47:48 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-02-19 03:52:17 -0500
commit96557115cb536a927f9e79deb7af50e8ba1491ea (patch)
tree7373b0b0224da74c6ce29c75eaeff188a499a399 /src/CMakeLists.txt
parentcc65a21e1224c9e732c882cbbe01fcb708527d1b (diff)
downloadlighttpd-git-96557115cb536a927f9e79deb7af50e8ba1491ea.tar.gz
[core] isolate plugins_*() funcs to main server
(future: might rename plugin.c -> plugins.c since the functions contained within are all plugins_*())
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 801bc684..7a72841d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -859,7 +859,7 @@ set(COMMON_SRC
base64.c buffer.c burl.c log.c
http_header.c http_kv.c keyvalue.c chunk.c
http_chunk.c fdevent.c fdevent_fdnode.c gw_backend.c
- stat_cache.c plugin.c http_etag.c array.c
+ stat_cache.c http_etag.c array.c
algo_md5.c algo_sha1.c algo_splaytree.c
configfile-glue.c
http-header-glue.c
@@ -896,6 +896,7 @@ add_executable(lighttpd
connections.c
h2.c
reqpool.c
+ plugin.c
sock_addr_cache.c
ls-hpack/lshpack.c
algo_xxhash.c