summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2022-01-05 08:29:10 +0000
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-05 06:52:24 -0500
commitb6bd11c15e62133426cf2acf189886237b97736c (patch)
tree3a7df593325fc5c8347165e2aedba0364163cea1 /src/CMakeLists.txt
parent3d0f64894823476165b7b31d5a508899cbfe2bec (diff)
downloadlighttpd-git-b6bd11c15e62133426cf2acf189886237b97736c.tar.gz
[core] server.core-files support for solaris (fixes #3135)
server.core-files support for solaris based systems. - using setpflags and disable process tracing protection for the current process. (edited: gstrauss) x-ref: "server.core-files support on Solaris based system" https://redmine.lighttpd.net/issues/3135
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cc94bf37..dc81096b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -155,6 +155,11 @@ set(CMAKE_EXTRA_INCLUDE_FILES time.h)
check_function_exists(timegm HAVE_TIMEGM)
set(CMAKE_EXTRA_INCLUDE_FILES)
+if(CMAKE_SYSTEM_NAME MATCHES "SunOS")
+check_include_files(priv.h HAVE_PRIV_H)
+check_function_exists(setpflags HAVE_SETPFLAGS)
+endif()
+
check_type_size(long SIZEOF_LONG)
check_type_size(off_t SIZEOF_OFF_T)