summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-01-08 15:46:24 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-08 18:09:42 -0500
commitc0ced4e82b13ea7e5566e640a34b3bd5ed5899c7 (patch)
treea4e29a311fb6940555d74636d263b4a79a1284fe /src/CMakeLists.txt
parent448621e0261712984c784e6b10ba940891060a3a (diff)
downloadlighttpd-git-c0ced4e82b13ea7e5566e640a34b3bd5ed5899c7.tar.gz
[build] collect Sun-specific headers and funcs
sendfilev() is Solaris-specific (and other OS have other alternatives)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 84122c5d..c845c1dd 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -180,6 +180,7 @@ check_include_files(priv.h HAVE_PRIV_H)
check_include_files(sys/devpoll.h HAVE_SYS_DEVPOLL_H)
check_include_files(sys/filio.h HAVE_SYS_FILIO_H)
check_function_exists(port_create HAVE_PORT_CREATE)
+check_function_exists(sendfilev HAVE_SENDFILEV)
check_function_exists(setpflags HAVE_SETPFLAGS)
endif()
@@ -217,7 +218,6 @@ check_function_exists(select HAVE_SELECT)
check_function_exists(sendfile HAVE_SENDFILE)
check_function_exists(send_file HAVE_SEND_FILE)
check_function_exists(sendfile64 HAVE_SENDFILE64)
-check_function_exists(sendfilev HAVE_SENDFILEV)
check_function_exists(sigaction HAVE_SIGACTION)
check_function_exists(signal HAVE_SIGNAL)
check_function_exists(splice HAVE_SPLICE)