summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-01-08 13:33:02 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-08 13:33:02 -0500
commitf95ca5ef3b2890abfac73e7a0d59695442b1e37a (patch)
tree8c24a52ddc79c8860c0f7ef37f18b4f94e64d47d /src/CMakeLists.txt
parent8c62a890e23f5853b1a562b03fe3e1bccc6e7664 (diff)
downloadlighttpd-git-f95ca5ef3b2890abfac73e7a0d59695442b1e37a.tar.gz
[build] use -fstack-protector-strong w/ extra warn
use -fstack-protector-strong if configured with --enable-extra-warnings
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f0513a9f..9852aaa8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -52,7 +52,7 @@ if(CMAKE_C_COMPILER_ID MATCHES "GNU" OR CMAKE_C_COMPILER_ID MATCHES "Clang")
option(BUILD_SANITIZE_UNDEFINED "Enable undefined sanitizer" OFF)
if(BUILD_EXTRA_WARNINGS)
- set(WARN_CFLAGS "-g -g2 -Wall -Wmissing-declarations -Wcast-align -Wsign-compare -Wnested-externs -Wpointer-arith -D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security")
+ set(WARN_CFLAGS "-g -g2 -Wall -Wmissing-declarations -Wcast-align -Wsign-compare -Wnested-externs -Wpointer-arith -D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Wformat -Werror=format-security")
set(WARN_LDFLAGS "")
# -Werror -Wbad-function-cast -Wmissing-prototypes
if(NOT BUILD_SANITIZE_ADDRESS)