summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-04-09 16:59:45 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2023-05-03 23:11:33 -0400
commit3915129e10cc0920ba9a9e1156108496bfcaa19a (patch)
tree94ffdea43fdef7845e6004c776b81a54242e1f2e /src/Makefile.am
parent7604dbd7fea5f2f4612fc12a51e37caef5785db8 (diff)
downloadlighttpd-git-3915129e10cc0920ba9a9e1156108496bfcaa19a.tar.gz
[mod_h2] HTTP/2 module: mod_h2
(mod_h2 module now available as build artifact of shared lib build, but is not yet used by lighttpd, in order to give package maintainers a chance to update release packages to contain mod_h2)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4678e524..4483a041 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -121,6 +121,11 @@ common_module_ldflags = -module -export-dynamic $(common_ldflags)
if !LIGHTTPD_STATIC
+lib_LTLIBRARIES += mod_h2.la
+mod_h2_la_SOURCES = h2.c ls-hpack/lshpack.c algo_xxhash.c
+mod_h2_la_LDFLAGS = $(common_module_ldflags)
+mod_h2_la_LIBADD = $(common_libadd) $(XXHASH_LIBS)
+
if BUILD_WITH_MAXMINDDB
lib_LTLIBRARIES += mod_maxminddb.la
mod_maxminddb_la_SOURCES = mod_maxminddb.c
@@ -480,6 +485,9 @@ lighttpd_SOURCES += mod_wolfssl.c
lighttpd_CPPFLAGS += $(WOLFSSL_CFLAGS)
lighttpd_LDADD += $(WOLFSSL_LIBS)
endif
+#(until switch to mod_h2)
+#lighttpd_SOURCES += h2.c ls-hpack/lshpack.c algo_xxhash.c
+#lighttpd_LDADD += $(XXHASH_LIBS)
else