summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-08-25 21:57:42 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2021-09-08 15:06:07 -0400
commitca2898f67896be77d4556c85a536975319a99dee (patch)
treea16f8896e23536fb72d3341204aed0fc63278e92 /src/Makefile.am
parent7a21b3856e30d307934a286c2b70aa9455820e68 (diff)
downloadlighttpd-git-ca2898f67896be77d4556c85a536975319a99dee.tar.gz
[tests] t/test_mod_indexfile
also remove some now-redundant tests from request.t and reduce scripts and directories under tests (because automake is sloooow and the fewer dirs, the better)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2115a732..ad343ec6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,6 +9,7 @@ noinst_PROGRAMS=\
t/test_keyvalue \
t/test_mod_access \
t/test_mod_evhost \
+ t/test_mod_indexfile \
t/test_mod_simple_vhost \
t/test_mod_staticfile \
t/test_mod_userdir \
@@ -26,6 +27,7 @@ TESTS=\
t/test_keyvalue$(EXEEXT) \
t/test_mod_access$(EXEEXT) \
t/test_mod_evhost$(EXEEXT) \
+ t/test_mod_indexfile$(EXEEXT) \
t/test_mod_simple_vhost$(EXEEXT) \
t/test_mod_staticfile$(EXEEXT) \
t/test_mod_userdir$(EXEEXT) \
@@ -662,6 +664,9 @@ t_test_mod_access_LDADD = $(LIBUNWIND_LIBS)
t_test_mod_evhost_SOURCES = t/test_mod_evhost.c buffer.c array.c log.c ck.c
t_test_mod_evhost_LDADD = $(LIBUNWIND_LIBS)
+t_test_mod_indexfile_SOURCES = t/test_mod_indexfile.c request.c base64.c buffer.c burl.c array.c fdevent.c http_etag.c http_header.c http_kv.c log.c sock_addr.c stat_cache.c algo_splaytree.c ck.c
+t_test_mod_indexfile_LDADD = $(LIBUNWIND_LIBS) $(FAM_LIBS)
+
t_test_mod_simple_vhost_SOURCES = t/test_mod_simple_vhost.c buffer.c array.c log.c ck.c
t_test_mod_simple_vhost_LDADD = $(LIBUNWIND_LIBS)