summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-09-22 00:33:20 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2022-09-23 03:39:22 -0400
commit62d5e56f6158d8073b482baf86564ce664ad681b (patch)
tree71a95ea758fb9944ee25fba898e8628630e8df77 /src/meson.build
parente3595eea4e1bd5c44fc90f17489159797846beb9 (diff)
downloadlighttpd-git-62d5e56f6158d8073b482baf86564ce664ad681b.tar.gz
[meson] set LIGHTTPD_VERSION_ID per version
lighttpd code is not tested for binary compatibility between releases Set a per-version LIGHTTPD_VERSION_ID to try to detect modules built against a different version of lighttpd.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 890bbfd5..8cd312cc 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -248,7 +248,7 @@ conf_data.set('HAVE_STRUCT_TM_GMTOFF', compiler.compiles('''
args: defs
))
-conf_data.set('LIGHTTPD_VERSION_ID', 10400)
+conf_data.set('LIGHTTPD_VERSION_ID', ''.join(['0x104', meson.project_version().split('.')[2]]))
conf_data.set_quoted('PACKAGE_NAME', meson.project_name())
conf_data.set_quoted('PACKAGE_VERSION', meson.project_version())
conf_data.set_quoted('LIBRARY_DIR', moduledir)