summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-02-13 01:07:33 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2023-02-13 16:06:43 -0500
commit6dd50d1d87a17a5cef69b84601876332ac594b1b (patch)
treea6dad699a7914d050bd34f30cc1e009b2ffaa65f /src/meson.build
parentadd03ac20f0215f5b675fa164bf2370168ebea9c (diff)
downloadlighttpd-git-6dd50d1d87a17a5cef69b84601876332ac594b1b.tar.gz
[build] skip build separate modules for built-ins
skip building separate modules for built-in modules Small modules with minimal dependencies are now built-in to lighttpd. All 12 of these modules have a memory footprint that is approximately the same as 1 single module built as a .dll due to mandatory minimum binary sections and memory page sizes (4k each).
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/meson.build b/src/meson.build
index ad399b11..fae883c2 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -743,29 +743,17 @@ test('test_mod', executable('test_mod',
))
modules = [
- [ 'mod_access', [ 'mod_access.c' ] ],
[ 'mod_accesslog', [ 'mod_accesslog.c' ] ],
[ 'mod_ajp13', [ 'mod_ajp13.c' ] ],
- [ 'mod_alias', [ 'mod_alias.c' ] ],
[ 'mod_auth', [ 'mod_auth.c', 'mod_auth_api.c' ], [ libcrypto ] ],
[ 'mod_authn_file', [ 'mod_authn_file.c' ], [ libcrypt, libcrypto ] ],
[ 'mod_deflate', [ 'mod_deflate.c' ], [ libbz2, libz, libzstd, libbrotli, libdeflate ] ],
[ 'mod_dirlisting', [ 'mod_dirlisting.c' ] ],
- [ 'mod_evhost', [ 'mod_evhost.c' ] ],
- [ 'mod_expire', [ 'mod_expire.c' ] ],
[ 'mod_extforward', [ 'mod_extforward.c' ] ],
- [ 'mod_fastcgi', [ 'mod_fastcgi.c' ], socket_libs ],
- [ 'mod_indexfile', [ 'mod_indexfile.c' ] ],
[ 'mod_proxy', [ 'mod_proxy.c' ], socket_libs ],
- [ 'mod_redirect', [ 'mod_redirect.c' ] ],
- [ 'mod_rewrite', [ 'mod_rewrite.c' ] ],
[ 'mod_rrdtool', [ 'mod_rrdtool.c' ] ],
- [ 'mod_scgi', [ 'mod_scgi.c' ], socket_libs ],
- [ 'mod_setenv', [ 'mod_setenv.c' ] ],
- [ 'mod_simple_vhost', [ 'mod_simple_vhost.c' ] ],
[ 'mod_sockproxy', [ 'mod_sockproxy.c' ] ],
[ 'mod_ssi', [ 'mod_ssi.c' ], socket_libs ],
- [ 'mod_staticfile', [ 'mod_staticfile.c' ] ],
[ 'mod_status', [ 'mod_status.c' ] ],
[ 'mod_userdir', [ 'mod_userdir.c' ] ],
[ 'mod_vhostdb', [ 'mod_vhostdb.c', 'mod_vhostdb_api.c' ] ],