summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-11-23 10:45:05 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-11-30 19:04:38 -0500
commitfcf0dc3e336a5d62c58036cdb8fc9f4c099b178e (patch)
treea94e7c0cf42cbdbf8308c559e104f7e44f279c8e /src/meson.build
parent326ace4ffd93582b86effee23c1014477c495eaf (diff)
downloadlighttpd-git-fcf0dc3e336a5d62c58036cdb8fc9f4c099b178e.tar.gz
[multiple] remove deprecated modules
remove deprecated modules: mod_evasive mod_secdownload mod_uploadprogress mod_usertrack These scheduled lighttpd behavior changes have been announced over the past year: * Continue gradual deprecation of "mini-application" lighttpd modules for which mod_magnet lua implementations are better and more flexible. Please post on lighttpd forums to share feedback if you use these modules. Forums: https://redmine.lighttpd.net/projects/lighttpd/boards * Deprecated: mod_evasive has been removed. mod_evasive can be replaced by mod_magnet and a few lines of lua: Replacement: https://wiki.lighttpd.net/ModMagnetExamples#lua-mod_evasive https://wiki.lighttpd.net/AbsoLUAtion#Fight-DDoS https://wiki.lighttpd.net/AbsoLUAtion#Mod_Security * Deprecated: mod_secdownload has been removed. mod_secdownload can be replaced by mod_magnet and a few lines of lua: Replacement: https://wiki.lighttpd.net/ModMagnetExamples#lua-mod_secdownload mod_secdownload historically uses insecure MD5 though SHA1, SHA256 available * Deprecated: mod_uploadprogress has been removed. mod_uploadprogress can be replaced by mod_magnet and a few lines of lua: Replacement: https://wiki.lighttpd.net/ModMagnetExamples#lua-mod_uploadprogress * Deprecated: mod_usertrack has been removed. mod_usertrack can be replaced by mod_magnet and a few lines of lua: Replacement: https://wiki.lighttpd.net/ModMagnetExamples#lua-mod_usertrack mod_usertrack historically uses insecure MD5.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/meson.build b/src/meson.build
index c6fcc051..57f8a76a 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -740,7 +740,6 @@ modules = [
[ 'mod_authn_file', [ 'mod_authn_file.c' ], [ libcrypt, libcrypto ] ],
[ 'mod_deflate', [ 'mod_deflate.c' ], [ libbz2, libz, libzstd, libbrotli, libdeflate ] ],
[ 'mod_dirlisting', [ 'mod_dirlisting.c' ] ],
- [ 'mod_evasive', [ 'mod_evasive.c' ] ],
[ 'mod_evhost', [ 'mod_evhost.c' ] ],
[ 'mod_expire', [ 'mod_expire.c' ] ],
[ 'mod_extforward', [ 'mod_extforward.c' ] ],
@@ -751,16 +750,13 @@ modules = [
[ 'mod_rewrite', [ 'mod_rewrite.c' ] ],
[ 'mod_rrdtool', [ 'mod_rrdtool.c' ] ],
[ 'mod_scgi', [ 'mod_scgi.c' ], socket_libs ],
- [ 'mod_secdownload', [ 'mod_secdownload.c', 'algo_hmac.c' ], libcrypto ],
[ 'mod_setenv', [ 'mod_setenv.c' ] ],
[ 'mod_simple_vhost', [ 'mod_simple_vhost.c' ] ],
[ 'mod_sockproxy', [ 'mod_sockproxy.c' ] ],
[ 'mod_ssi', [ 'mod_ssi.c' ], socket_libs ],
[ 'mod_staticfile', [ 'mod_staticfile.c' ] ],
[ 'mod_status', [ 'mod_status.c' ] ],
- [ 'mod_uploadprogress', [ 'mod_uploadprogress.c' ] ],
[ 'mod_userdir', [ 'mod_userdir.c' ] ],
- [ 'mod_usertrack', [ 'mod_usertrack.c' ], libcrypto ],
[ 'mod_vhostdb', [ 'mod_vhostdb.c', 'mod_vhostdb_api.c' ] ],
[ 'mod_webdav', [ 'mod_webdav.c' ], [ libsqlite3, libuuid, libxml2, libelftc ] ],
[ 'mod_wstunnel', [ 'mod_wstunnel.c' ], libcrypto ],