summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2016-10-18 17:44:56 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2016-10-18 17:47:33 -0400
commitb11d0598436e64b34d0ffffcfa04346c9cf8e8f9 (patch)
tree0a573ee6241b7c26230729822292cedc78c83967 /tests/CMakeLists.txt
parent4943dac8515ca3cf649f0300febd388a4e396865 (diff)
downloadlighttpd-git-b11d0598436e64b34d0ffffcfa04346c9cf8e8f9.tar.gz
[cmake] build fcgi-auth, fcgi-responder for tests
Aside: must have cmake enable building openssl for tests to pass due to tests/lighttpd.conf including config options requiring openssl algorithms in mod_secdownload.c: (secdownload.algorithm = "hmac-sha1") (secdownload.algorithm = "hmac-sha256") $ cmake -L . $ cmake -DWITH_OPENSSL:BOOL=ON . $ make -j 4 -k $ make test x-ref: https://blog.lighttpd.net/articles/2006/12/25/1-5-0-goes-cmake/
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 699df828..5b0330c5 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,15 @@
+check_include_files(fastcgi.h HAVE_FASTCGI_H)
+check_include_files(fastcgi/fastcgi.h HAVE_FASTCGI_FASTCGI_H)
+if(HAVE_FASTCGI_H OR HAVE_FASTCGI_FASTCGI_H)
+ check_library_exists(fcgi FCGI_Accept "" HAVE_FASTCGI)
+ if(HAVE_FASTCGI)
+ add_executable(fcgi-auth fcgi-auth.c)
+ add_executable(fcgi-responder fcgi-responder.c)
+ target_link_libraries(fcgi-auth fcgi)
+ target_link_libraries(fcgi-responder fcgi)
+ endif()
+endif()
+
set(T_FILES
prepare.sh
cachable.t