summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-07-07 15:00:31 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2021-09-04 08:08:26 -0400
commitf47261159720e90dc4444082b2a28bd1491634d4 (patch)
treeb122b826a424df0013b77a91e6f4942400aa1f97 /tests/CMakeLists.txt
parent91472ab7681b26f36b813f3b245c0e98f91b4c3f (diff)
downloadlighttpd-git-f47261159720e90dc4444082b2a28bd1491634d4.tar.gz
[tests] combine *.t using tests/lighttpd.conf
combine tests/*.t using tests/lighttpd.conf into tests/request.t Platforms which are horrifically slow starting processes (e.g. Windows) take much more time to start and stop lighttpd many times for independent *.t instances run through the Perl Test::More framework
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 0db1a440..0b81ba9b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -3,24 +3,11 @@ add_executable(scgi-responder scgi-responder.c)
set(T_FILES
prepare.sh
- core-404-handler.t
+ request.t
core-condition.t
- core-keepalive.t
- core-request.t
- core-response.t
core-var-include.t
- lowercase.t
- mod-auth.t
- mod-cgi.t
- mod-deflate.t
- mod-extforward.t
mod-fastcgi.t
- mod-proxy.t
- mod-secdownload.t
- mod-setenv.t
- mod-ssi.t
- request.t
- symlink.t
+ mod-scgi.t
cleanup.sh
)