summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-12-20 21:32:50 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2020-12-23 03:49:43 -0500
commitfc01b820ecf497c0b3bf4dbf82f83852d2c7aefd (patch)
tree968ef15af5d8bb195e9e124b96f723cf1a773b1a /tests/CMakeLists.txt
parentc68a7b4552b49052b3876a3e41d772ab051a1d3c (diff)
downloadlighttpd-git-fc01b820ecf497c0b3bf4dbf82f83852d2c7aefd.tar.gz
[tests] remove FastCGI test dependency on libfcgi
- rewrite fcgi-responder as standalone app fcgi-responder is now a minimal, standalone FastCGI server for tests - remove dependency on fcgi-devel package - merge fcgi-auth into fcgi-responder
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 51d534bd..e199811b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,14 +1,4 @@
-check_include_files(fastcgi.h HAVE_FASTCGI_H)
-check_include_files(fastcgi/fastcgi.h HAVE_FASTCGI_FASTCGI_H)
-if(HAVE_FASTCGI_H OR HAVE_FASTCGI_FASTCGI_H)
- check_library_exists(fcgi FCGI_Accept "" HAVE_FASTCGI)
- if(HAVE_FASTCGI)
- add_executable(fcgi-auth fcgi-auth.c)
- add_executable(fcgi-responder fcgi-responder.c)
- target_link_libraries(fcgi-auth fcgi)
- target_link_libraries(fcgi-responder fcgi)
- endif()
-endif()
+add_executable(fcgi-responder fcgi-responder.c)
add_executable(scgi-responder scgi-responder.c)
set(T_FILES