summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-12-20 21:32:50 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2020-12-23 03:49:43 -0500
commitfc01b820ecf497c0b3bf4dbf82f83852d2c7aefd (patch)
tree968ef15af5d8bb195e9e124b96f723cf1a773b1a /tests/Makefile.am
parentc68a7b4552b49052b3876a3e41d772ab051a1d3c (diff)
downloadlighttpd-git-fc01b820ecf497c0b3bf4dbf82f83852d2c7aefd.tar.gz
[tests] remove FastCGI test dependency on libfcgi
- rewrite fcgi-responder as standalone app fcgi-responder is now a minimal, standalone FastCGI server for tests - remove dependency on fcgi-devel package - merge fcgi-auth into fcgi-responder
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7edc1a5a..f6955fad 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,16 +1,9 @@
# lighttpd.conf and conformance.pl expect this directory
testdir=$(srcdir)/tmp/lighttpd/
-if CHECK_WITH_FASTCGI
-check_PROGRAMS=fcgi-auth fcgi-responder scgi-responder
-
-fcgi_auth_SOURCES=fcgi-auth.c
-fcgi_auth_LDADD=-lfcgi
+check_PROGRAMS=fcgi-responder scgi-responder
fcgi_responder_SOURCES=fcgi-responder.c
-fcgi_responder_LDADD=-lfcgi
-endif
-
scgi_responder_SOURCES=scgi-responder.c
TESTS=\