summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-01-03 16:14:45 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-04 04:25:26 -0500
commitb9d58fa723cd3789b8fb2475696a7c596fefc961 (patch)
treeb5a799fae2ea49fc420e5cfb1368ca03de4e4af4 /tests/meson.build
parenta931b1fce2a33d6f5ba83d585f5ccefdadaf35e1 (diff)
downloadlighttpd-git-b9d58fa723cd3789b8fb2475696a7c596fefc961.tar.gz
[build] cmake,meson socket libs for win32, Illumos (fixes #3130)
(thx devnexen) cmake, meson: specify socket libs for win32, Illumos x-ref: "Solaris build fix proposal" https://redmine.lighttpd.net/issues/3130
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build15
1 files changed, 13 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index ed4734d0..44355777 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,11 +1,22 @@
+compiler = meson.get_compiler('c')
+socket_libs = []
+if target_machine.system() == 'windows'
+ socket_libs = [ compiler.find_library('ws2_32') ]
+endif
+if target_machine.system() == 'sunos'
+ socket_libs = [ compiler.find_library('socket')
+ , compiler.find_library('nsl')
+ ]
+endif
+
executable('fcgi-responder',
sources: 'fcgi-responder.c',
- dependencies: common_flags,
+ dependencies: [ common_flags, socket_libs ]
)
executable('scgi-responder',
sources: 'scgi-responder.c',
- dependencies: common_flags,
+ dependencies: [ common_flags, socket_libs ]
)
env = environment()