summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-12-20 21:32:50 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2020-12-23 03:49:43 -0500
commitfc01b820ecf497c0b3bf4dbf82f83852d2c7aefd (patch)
tree968ef15af5d8bb195e9e124b96f723cf1a773b1a /tests/meson.build
parentc68a7b4552b49052b3876a3e41d772ab051a1d3c (diff)
downloadlighttpd-git-fc01b820ecf497c0b3bf4dbf82f83852d2c7aefd.tar.gz
[tests] remove FastCGI test dependency on libfcgi
- rewrite fcgi-responder as standalone app fcgi-responder is now a minimal, standalone FastCGI server for tests - remove dependency on fcgi-devel package - merge fcgi-auth into fcgi-responder
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build17
1 files changed, 4 insertions, 13 deletions
diff --git a/tests/meson.build b/tests/meson.build
index f6c501ac..9ecc9192 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,16 +1,7 @@
-if conf_data.get('HAVE_FASTCGI_H') or conf_data.get('HAVE_FASTCGI_FASTCGI_H')
- libfcgi = compiler.find_library('fcgi', required: false)
- if libfcgi.found()
- executable('fcgi-auth',
- sources: 'fcgi-auth.c',
- dependencies: common_flags + [ libfcgi ],
- )
- executable('fcgi-responder',
- sources: 'fcgi-responder.c',
- dependencies: common_flags + [ libfcgi ],
- )
- endif
-endif
+executable('fcgi-responder',
+ sources: 'fcgi-responder.c',
+ dependencies: common_flags,
+)
executable('scgi-responder',
sources: 'scgi-responder.c',