summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 8e084edc..57b66d8f 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -400,6 +400,19 @@ if get_option('with_pgsql')
conf_data.set('HAVE_PGSQL', true)
endif
+if get_option('with_sasl')
+ libsasl = dependency('sasl2', required: false)
+ if libsasl.found()
+ libsasl = [ libsasl2 ]
+ else
+ libsasl = [ compiler.find_library('sasl2') ]
+ if not(compiler.has_function('sasl_server_init', args: defs, dependencies: libsasl, prefix: '#include <sasl/sasl.h>'))
+ error('Couldn\'t find sasl/sasl.h or sasl_server_init in libsasl2')
+ endif
+ endif
+ conf_data.set('HAVE_SASL', true)
+endif
+
#if get_option('with_valgrind')
#endif
@@ -799,6 +812,12 @@ if get_option('with_openssl')
]
endif
+if get_option('with_sasl')
+ modules += [
+ [ 'mod_authn_sasl', [ 'mod_authn_sasl.c' ], libsasl2 ],
+ ]
+endif
+
foreach mod: modules
mod_name = mod.get(0)
mod_sources = mod.get(1)