summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Kukuk <5908016+thkukuk@users.noreply.github.com>2021-11-02 11:46:24 +0100
committerGitHub <noreply@github.com>2021-11-02 11:46:24 +0100
commit04109c25a7dbd11404f7f23a9a405b9b9d6b7246 (patch)
tree868531e48a6b1b0f332f30ae9c14dac74762b249 /configure.ac
parent00a46bcead2857002ed720f22b558b6f6d349fc8 (diff)
downloadlinux-pam-git-04109c25a7dbd11404f7f23a9a405b9b9d6b7246.tar.gz
Only include vendordir in manual page if set (#401)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c06bc7dd..eb98d69a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -507,9 +507,9 @@ AC_ARG_ENABLE([vendordir],
if test -n "$enable_vendordir"; then
AC_DEFINE_UNQUOTED([VENDORDIR], ["$enable_vendordir"],
[Directory for distribution provided configuration files])
- STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir'"
+ STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir' --stringparam profile.condition 'with_vendordir'"
else
- STRINGPARAM_VENDORDIR="--stringparam vendordir '<vendordir>'"
+ STRINGPARAM_VENDORDIR="--stringparam profile.condition 'without_vendordir'"
fi
AC_SUBST([STRINGPARAM_VENDORDIR])