summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-08-07 18:00:00 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-08-07 18:00:00 +0000
commitc0b3c9fa05424f9606b0c348e0052bfb3bda3fa9 (patch)
tree6a7a0ac7a1abcec8c3f59c8a4bf83f96ee50e7d9 /configure.ac
parent0ca78051452625ec7c30f51f9408ea4c40de713e (diff)
downloadlinux-pam-git-c0b3c9fa05424f9606b0c348e0052bfb3bda3fa9.tar.gz
build: rename PIE_* AC_SUBST variables to EXE_*
There are going to be other options added to CFLAGS and LDFLAGS of executables made along with modules. * configure.ac (EXE_CFLAGS, EXE_LDFLAGS): New variables initialized from PIE_CFLAGS and PIE_LDFLAGS, respectively. AC_SUBST them instead of PIE_CFLAGS and PIE_LDFLAGS. All users updated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 98e52410..36f2cbe1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -208,8 +208,10 @@ AS_IF([test "$enable_pie" = yes],
[PIE_CFLAGS=
PIE_LDFLAGS=])
-AC_SUBST(PIE_CFLAGS)
-AC_SUBST(PIE_LDFLAGS)
+EXE_CFLAGS="$PIE_CFLAGS"
+EXE_LDFLAGS="$PIE_LDFLAGS"
+AC_SUBST(EXE_CFLAGS)
+AC_SUBST(EXE_LDFLAGS)
dnl