summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJason Gerecke <jason.gerecke@wacom.com>2022-02-19 12:16:55 -0800
committerPeter Hutterer <peter.hutterer@who-t.net>2022-02-22 10:41:51 +1000
commit5390ebb2f55f40a3d41f4352447fb603ab4e2fd2 (patch)
treea48cfbd0c510346bb9bed76111516de134123121 /meson.build
parente217fe67690ff8d00af6ccc2bbe65720af21a979 (diff)
downloadxf86-input-wacom-5390ebb2f55f40a3d41f4352447fb603ab4e2fd2.tar.gz
Enable additional compiler warnings by default
Removes the two `-Wno-xxxx` directives from out default set of build flags enables several new warnings as well. Signed-off-by: Jason Gerecke <jason.gerecke@wacom.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index eeb4d31..d61fdb3 100644
--- a/meson.build
+++ b/meson.build
@@ -25,7 +25,6 @@ cflags = [
'-Wall',
'-Wextra',
'-Wno-unused-parameter',
- '-Wno-sign-compare', # lots of work to get rid of this
'-Wmissing-prototypes',
'-Wstrict-prototypes',
'-Wlogical-op',
@@ -37,8 +36,13 @@ cflags = [
'-Wredundant-decls',
'-Wincompatible-pointer-types',
'-Wformat=2',
- '-Wno-missing-field-initializers',
+ '-Wformat-overflow=2',
+ '-Wformat-signedness',
+ '-Wformat-truncation=2',
'-Wmissing-declarations',
+ '-Wshift-overflow=2',
+ '-Wstrict-overflow=2',
+ '-Wswitch-enum',
'-fvisibility=hidden',
]