summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2022-02-09 09:50:07 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2022-02-09 12:47:32 +1000
commitad8de302874ab2075928ddd4e3f762251fef0703 (patch)
treeec3495639e914ca8d90ffa2331008e4cb025045e /meson.build
parent291192a5e5ac329cc5d355858d6e69337c65be1d (diff)
downloadxf86-input-wacom-ad8de302874ab2075928ddd4e3f762251fef0703.tar.gz
Drop the build system checks for -wrap
No longer needed as of ff94040208c9da3411753e1ffe554e6c80b87dd7 Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 1 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index ef6c816..8610a67 100644
--- a/meson.build
+++ b/meson.build
@@ -307,19 +307,7 @@ if get_option('serial-device-support')
endif
# Tests
-have_wrap = cc.links('''
-void __wrap_exit (int s) {
- __real_exit (0);
-}
-int main(void) {
- exit(1);
-}''',
-args: '-Wl,-wrap,exit')
-
-if get_option('unittests').enabled() and not have_wrap
- error('ld -wrap support required to build unit tests')
-endif
-build_unittests = have_wrap and not get_option('unittests').disabled()
+build_unittests = not get_option('unittests').disabled()
if build_unittests
xsetwacom_test = executable(