summaryrefslogtreecommitdiff
path: root/bolt/CMakeLists.txt
diff options
context:
space:
mode:
authorGabriel Poesia <gpoesia@fb.com>2016-03-11 11:30:30 -0800
committerMaksim Panchenko <maks@fb.com>2016-03-11 11:30:30 -0800
commit80ea31b24e8f1c1be031b4899342ebd83881be48 (patch)
tree7d93748c7b8669debbc3fe6dc2d1502a30fbf6a6 /bolt/CMakeLists.txt
parente7e9e15b90b4f8301f3167b9446d491484cdd217 (diff)
downloadllvm-80ea31b24e8f1c1be031b4899342ebd83881be48.tar.gz
Write updated .debug_aranges section after optimizations.
Summary: Write the .debug_aranges section after optimizations to the output binary. Each function generates at least one range and at most two (one extra for its cold part). The writing is done manually because LLVM's implementation is tied to the output of .debug_info (see EmitGenDwarfInfo and EmitGenDwarfARanges in lib/MC/MCDwarf.cpp), which we don't want to trigger right now. (cherry picked from FBD3043108)
Diffstat (limited to 'bolt/CMakeLists.txt')
-rw-r--r--bolt/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/bolt/CMakeLists.txt b/bolt/CMakeLists.txt
index 7b25d1e27984..3d97144787dc 100644
--- a/bolt/CMakeLists.txt
+++ b/bolt/CMakeLists.txt
@@ -17,6 +17,7 @@ add_llvm_tool(llvm-bolt
BinaryContext.cpp
BinaryFunction.cpp
DataReader.cpp
+ DebugArangesWriter.cpp
DebugLineTableRowRef.cpp
Exceptions.cpp
RewriteInstance.cpp