summaryrefslogtreecommitdiff
path: root/bolt/CMakeLists.txt
diff options
context:
space:
mode:
authorMaksim Panchenko <maks@fb.com>2017-02-16 14:57:57 -0800
committerMaksim Panchenko <maks@fb.com>2017-02-16 14:57:57 -0800
commit88244a10bb205f650a44590dcc8e184cd240a26d (patch)
treef8ddb506a17e766097f331d4ba81e5ecc7684b7e /bolt/CMakeLists.txt
parentf06a1455eac57aa3ddcbc156c8b9496224dc9539 (diff)
downloadllvm-88244a10bb205f650a44590dcc8e184cd240a26d.tar.gz
[BOLT] Move BOLT passes under Passes subdirectory (NFC).
Summary: Move passes under Passes subdirectory. Move inlining passes under Passes/Inliner.* (cherry picked from FBD4575832)
Diffstat (limited to 'bolt/CMakeLists.txt')
-rw-r--r--bolt/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/bolt/CMakeLists.txt b/bolt/CMakeLists.txt
index a1c5f9e7f732..fd9aa6884b72 100644
--- a/bolt/CMakeLists.txt
+++ b/bolt/CMakeLists.txt
@@ -1,7 +1,9 @@
add_subdirectory(merge-fdata)
+add_subdirectory(Passes)
set(LLVM_LINK_COMPONENTS
${LLVM_TARGETS_TO_BUILD}
+ BOLTPasses
CodeGen
Core
DebugInfoDWARF
@@ -18,13 +20,10 @@ add_llvm_tool(llvm-bolt
BinaryBasicBlock.cpp
BinaryContext.cpp
BinaryFunction.cpp
- BinaryPasses.cpp
BinaryPassManager.cpp
DataReader.cpp
DebugData.cpp
Exceptions.cpp
- FrameOptimizerPass.cpp
RewriteInstance.cpp
- ReorderAlgorithm.cpp
DWARFRewriter.cpp
)