summaryrefslogtreecommitdiff
path: root/bolt/CMakeLists.txt
diff options
context:
space:
mode:
authorMaksim Panchenko <maks@fb.com>2017-12-13 23:12:01 -0800
committerMaksim Panchenko <maks@fb.com>2017-12-13 23:12:01 -0800
commitb6cb112febefef75d479f528fc09a52b806fb333 (patch)
tree7d14cbf261e525a9bde1a72d205eae05c9c3aef3 /bolt/CMakeLists.txt
parentf8f52d01d012404ed76ea3dca703bd0776fd3b05 (diff)
downloadllvm-b6cb112febefef75d479f528fc09a52b806fb333.tar.gz
[BOLT] New profile format
Summary: A new profile that is more resilient to minor binary modifications. BranchData is eliminated. For calls, the data is converted into instruction annotations if the profile matches a function. If a profile cannot be matched, AllCallSites data should have call sites profiles. The new profile format is YAML, which is quite verbose. It still takes less space than the older format because we avoid function name repetition. The plan is to get rid of the old profile format eventually. merge-fdata does not work with the new format yet. (cherry picked from FBD6753747)
Diffstat (limited to 'bolt/CMakeLists.txt')
-rw-r--r--bolt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/bolt/CMakeLists.txt b/bolt/CMakeLists.txt
index 959b19915f10..5e6ce6fe7b8c 100644
--- a/bolt/CMakeLists.txt
+++ b/bolt/CMakeLists.txt
@@ -71,6 +71,8 @@ add_llvm_tool(llvm-bolt
DebugData.cpp
DWARFRewriter.cpp
Exceptions.cpp
+ ProfileReader.cpp
+ ProfileWriter.cpp
RewriteInstance.cpp
)