summaryrefslogtreecommitdiff
path: root/bolt/CMakeLists.txt
diff options
context:
space:
mode:
authorBohan Ren <brian0129@fb.com>2017-06-13 16:29:39 -0700
committerMaksim Panchenko <maks@fb.com>2017-06-13 16:29:39 -0700
commitec304396c3e5b57a84aa26a99b6de70eab3637e6 (patch)
treecaf09aa1dbf88aef2e99874d27a8ca72dd5252a9 /bolt/CMakeLists.txt
parent3469396269318b409bcd4ffcae154fe5f6de8764 (diff)
downloadllvm-ec304396c3e5b57a84aa26a99b6de70eab3637e6.tar.gz
[BOLT] Call Distance Metric
Summary: Designed a new metric, which shows 93.46% correltation with Cache Miss and 86% correlation with CPU Time. Definition: One can get all the traversal path for each function. And for each traversal, we will define a distance. The distance represents how far two connected basic blocks are. Therefore, for each traversal, I will go through the basic blocks one by one, until the end of the traversal and sum up the distance for the neighboring basic blocks. Distance between two connected basic blocks is the distance of the centers of two blocks in the binary file. (cherry picked from FBD5242526)
Diffstat (limited to 'bolt/CMakeLists.txt')
-rw-r--r--bolt/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/bolt/CMakeLists.txt b/bolt/CMakeLists.txt
index c8e2f3e3c45b..0ddfb353a599 100644
--- a/bolt/CMakeLists.txt
+++ b/bolt/CMakeLists.txt
@@ -64,6 +64,7 @@ add_llvm_tool(llvm-bolt
BinaryContext.cpp
BinaryFunction.cpp
BinaryPassManager.cpp
+ CalcCacheMetrics.cpp
DataReader.cpp
DebugData.cpp
DWARFRewriter.cpp