summaryrefslogtreecommitdiff
path: root/clang-tools-extra/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Lorenz <arphaman@gmail.com>2019-08-27 18:36:08 +0000
committerAlex Lorenz <arphaman@gmail.com>2019-08-27 18:36:08 +0000
commit559ae14c9b6cf203e0e7495892080e52e89c1ea0 (patch)
tree1a4e5f547fad08a4fcded9e8b0d451cce44ae4ac /clang-tools-extra/CMakeLists.txt
parent2f2feebf4d30a03793e587e8cbcde73e693c1d13 (diff)
downloadllvm-559ae14c9b6cf203e0e7495892080e52e89c1ea0.tar.gz
Remove clang-tidy-vs from clang-tools-extra (PR41791)
The clang-tidy-vs visual studio plugin in clang-tools-extra contains a security vulnerability in the YamlDotNet package [1]. I posted to cfe-dev [2], asking if there was anyone who was interested in updating the the plugin to address the vulnerability. Reid mentioned that Zach (the original committer), said that there's another plugin (Clang Power Tools) that provides clang-tidy support, with additional extra features, so it would be ok to remove clang-tidy-vs. This commit removes the plugin to address the security vulnerability, and adds a section to the release notes that mentions that the plugin was removed, and suggests to use Clang Power Tools. Fixes PR 41791. [1]: https://nvd.nist.gov/vuln/detail/CVE-2018-1000210 [2]: http://lists.llvm.org/pipermail/cfe-dev/2019-August/063196.html Differential Revision: https://reviews.llvm.org/D66813 llvm-svn: 370096
Diffstat (limited to 'clang-tools-extra/CMakeLists.txt')
-rw-r--r--clang-tools-extra/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/clang-tools-extra/CMakeLists.txt b/clang-tools-extra/CMakeLists.txt
index dbb89e6257ff..57bb97057560 100644
--- a/clang-tools-extra/CMakeLists.txt
+++ b/clang-tools-extra/CMakeLists.txt
@@ -4,7 +4,6 @@ add_subdirectory(clang-apply-replacements)
add_subdirectory(clang-reorder-fields)
add_subdirectory(modularize)
add_subdirectory(clang-tidy)
-add_subdirectory(clang-tidy-vs)
add_subdirectory(clang-change-namespace)
add_subdirectory(clang-doc)