summaryrefslogtreecommitdiff
path: root/clang-tools-extra/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-07-14 22:15:29 +0000
committerAlp Toker <alp@nuanti.com>2014-07-14 22:15:29 +0000
commit6462e9e6950ed4860a6210effe66b4435838eefa (patch)
tree441db99e4cf4b11574eb0b9199a6fca08f4842aa /clang-tools-extra/CMakeLists.txt
parent5a1c4b82830214504c9e8c4a7bc0492478035605 (diff)
downloadllvm-6462e9e6950ed4860a6210effe66b4435838eefa.tar.gz
Fix build when various clang feature flags are enabled/disabled
llvm-svn: 212994
Diffstat (limited to 'clang-tools-extra/CMakeLists.txt')
-rw-r--r--clang-tools-extra/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/clang-tools-extra/CMakeLists.txt b/clang-tools-extra/CMakeLists.txt
index a0d5e2eeecc6..33a5ce9a3683 100644
--- a/clang-tools-extra/CMakeLists.txt
+++ b/clang-tools-extra/CMakeLists.txt
@@ -1,13 +1,21 @@
+if(CLANG_ENABLE_REWRITER)
add_subdirectory(clang-apply-replacements)
add_subdirectory(clang-modernize)
-add_subdirectory(clang-query)
-add_subdirectory(clang-tidy)
add_subdirectory(modularize)
add_subdirectory(module-map-checker)
-add_subdirectory(pp-trace)
add_subdirectory(remove-cstr-calls)
+endif()
+if(CLANG_ENABLE_STATIC_ANALYZER)
+add_subdirectory(clang-tidy)
+endif()
+
+add_subdirectory(clang-query)
+add_subdirectory(pp-trace)
add_subdirectory(tool-template)
# Add the common testsuite after all the tools.
+# TODO: Support tests with more granularity when features are off?
+if(CLANG_ENABLE_REWRITER AND CLANG_ENABLE_STATIC_ANALYZER)
add_subdirectory(test)
add_subdirectory(unittests)
+endif()