summaryrefslogtreecommitdiff
path: root/clang-tools-extra/CMakeLists.txt
diff options
context:
space:
mode:
authorSam McCall <sam.mccall@gmail.com>2022-03-08 19:31:32 +0100
committerSam McCall <sam.mccall@gmail.com>2022-03-16 00:14:11 +0100
commitb97856c4cfe7efb13887d5691002a7aa38440924 (patch)
treeb06712aec669be0c72efc154c4eae6e5ccd535f0 /clang-tools-extra/CMakeLists.txt
parent78d29203ad7496dc3c4cd96310db1d6ad3a25e3d (diff)
downloadllvm-b97856c4cfe7efb13887d5691002a7aa38440924.tar.gz
[pseudo] Move pseudoparser from clang to clang-tools-extra
This should make clearer that: - it's not part of clang proper - there's no expectation to update it along with clang (beyond green tests) - clang should not depend on it This is intended to be expose a library, so unlike other tools has a split between include/ and lib/. The main renames are: clang/lib/Tooling/Syntax/Pseudo/* => clang-tools-extra/pseudo/lib/* clang/include/clang/Tooling/Syntax/Pseudo/* => clang-tools-extra/pseudo/include/clang-pseudo/* clang/tools/clang/pseudo/* => clang-tools-extra/pseudo/tool/* clang/test/Syntax/* => clang-tools-extra/pseudo/test/* clang/unittests/Tooling/Syntax/Pseudo/* => clang-tools-extra/pseudo/unittests/* #include "clang/Tooling/Syntax/Pseudo/*" => #include "clang-pseudo/*" namespace clang::syntax::pseudo => namespace clang::pseudo check-clang => check-clang-pseudo clangToolingSyntaxPseudo => clangPseudo The clang-pseudo and ClangPseudoTests binaries are not renamed. See discussion around: https://discourse.llvm.org/t/rfc-a-c-pseudo-parser-for-tooling/59217/50 Differential Revision: https://reviews.llvm.org/D121233
Diffstat (limited to 'clang-tools-extra/CMakeLists.txt')
-rw-r--r--clang-tools-extra/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang-tools-extra/CMakeLists.txt b/clang-tools-extra/CMakeLists.txt
index 7b8274a97336..285e5529e6fc 100644
--- a/clang-tools-extra/CMakeLists.txt
+++ b/clang-tools-extra/CMakeLists.txt
@@ -15,6 +15,7 @@ add_subdirectory(clang-include-fixer)
add_subdirectory(clang-move)
add_subdirectory(clang-query)
add_subdirectory(pp-trace)
+add_subdirectory(pseudo)
add_subdirectory(tool-template)
# Add the common testsuite after all the tools.