summaryrefslogtreecommitdiff
path: root/clang-tools-extra/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jasper <djasper@google.com>2013-07-29 08:19:24 +0000
committerDaniel Jasper <djasper@google.com>2013-07-29 08:19:24 +0000
commitd07c840e6a125e954bfe015062c861369aae870e (patch)
tree23f7638f25cb4755ed1bfc24aeb2c3b2cc418d67 /clang-tools-extra/CMakeLists.txt
parentbaca389e28985d57f59e42d745696bdf7ed56af2 (diff)
downloadllvm-d07c840e6a125e954bfe015062c861369aae870e.tar.gz
Initial architecture for clang-tidy.
This is the first version of a possible clang-tidy architecture. The purpose of clang-tidy is to detect errors in adhering to common coding patterns, e.g. described in the LLVM Coding Standards. This is still heavily in flux. Review: http://llvm-reviews.chandlerc.com/D884 llvm-svn: 187345
Diffstat (limited to 'clang-tools-extra/CMakeLists.txt')
-rw-r--r--clang-tools-extra/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang-tools-extra/CMakeLists.txt b/clang-tools-extra/CMakeLists.txt
index 6a4d3793215d..fdd2426ffb70 100644
--- a/clang-tools-extra/CMakeLists.txt
+++ b/clang-tools-extra/CMakeLists.txt
@@ -2,6 +2,7 @@ add_subdirectory(remove-cstr-calls)
add_subdirectory(tool-template)
add_subdirectory(cpp11-migrate)
add_subdirectory(modularize)
+add_subdirectory(clang-tidy)
# Add the common testsuite after all the tools.
add_subdirectory(test)