summaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorH. Vetinari <h.vetinari@gmx.com>2022-08-25 08:35:46 +0200
committerTobias Hieta <tobias@hieta.se>2022-08-25 08:36:01 +0200
commit0f28d4856630f8b5c6708069b4e35d7345838d6b (patch)
tree1a31867cde31417b9aa7f42e687befb731bba0b7 /clang/CMakeLists.txt
parent70770a16bcfa70b2a4b38d55ab8097f9f92c2326 (diff)
downloadllvm-0f28d4856630f8b5c6708069b4e35d7345838d6b.tar.gz
SONAME introduce option CLANG_FORCE_MATCHING_LIBCLANG_SOVERSION
This reverts commit bc39d7bdd4977a953b2e102f8f7eb479ad78984e. rename CLANG_SONAME to LIBCLANG_SOVERSION [clang][cmake] introduce option CLANG_FORCE_MATCHING_LIBCLANG_SOVERSION Differential Revision: https://reviews.llvm.org/D132486
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 332df8f3b8bf..2b1e968da396 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -463,6 +463,12 @@ if(CLANG_ENABLE_ARCMT)
set(CLANG_ENABLE_OBJC_REWRITER ON)
endif()
+# This option is a stop-gap, we should commit to removing this as
+# soon as possible. See discussion:
+# https://discourse.llvm.org/t/rationale-for-removing-versioned-libclang-middle-ground-to-keep-it-behind-option/
+option(CLANG_FORCE_MATCHING_LIBCLANG_SOVERSION
+ "Force the SOVERSION of libclang to be equal to CLANG_MAJOR" ON)
+
# Clang version information
set(CLANG_EXECUTABLE_VERSION
"${CLANG_VERSION_MAJOR}" CACHE STRING