summaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorFangrui Song <i@maskray.me>2022-10-25 00:24:25 -0700
committerFangrui Song <i@maskray.me>2022-10-25 00:24:25 -0700
commit3a3603ff99ffd7dd7c8d166ba6d15078e33a5f71 (patch)
tree98c50f40f4b043c23d4662d4334ec58d387117a1 /clang/CMakeLists.txt
parente6c8418aab0bd5e459f3b286a603e5b88a4fb1a1 (diff)
downloadllvm-3a3603ff99ffd7dd7c8d166ba6d15078e33a5f71.tar.gz
[clang] Replace BACKEND_PACKAGE_STRING with LLVM_VERSION_STRING
420d7ccbac0f499a6ff9595bdbfa99cd3376df22 introduced BACKEND_PACKAGE_STRING to replace `PACKAGE_VERSION` (llvm/Config/config.h) to support standalone builds. This is used in the output of `clang -cc1 -v`. Since llvm-config.h is available for both standalone and non-standalone builds, we can just use `LLVM_VERSION_STRING` from llvm-config.h. clang/cmake/modules/AddClang.cmake uses `VERSION_STRING "${CLANG_VERSION} (${BACKEND_PACKAGE_STRING})"`. Just simplify it to `"${CLANG_VERSION}"` so that we can remove the CMake variable BACKEND_PACKAGE_STRING. Reviewed By: tstellar Differential Revision: https://reviews.llvm.org/D136660
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 202a5d266794..7c41eadc7bf9 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -134,10 +134,6 @@ if(CLANG_BUILT_STANDALONE)
umbrella_lit_testsuite_begin(check-all)
endif() # LLVM_INCLUDE_TESTS
-
- set(BACKEND_PACKAGE_STRING "LLVM ${LLVM_PACKAGE_VERSION}")
-else()
- set(BACKEND_PACKAGE_STRING "${PACKAGE_STRING}")
endif() # standalone
if(NOT DEFINED LLVM_COMMON_CMAKE_UTILS)