summaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorSinan Lin <sinan.lin@linux.alibaba.com>2022-09-05 22:00:00 +0800
committerLin Sinan <linsinan.lsn@alibaba-inc.com>2022-09-07 11:04:12 +0800
commit73593145cb5b6bbb474e2c53153aabdb362731d5 (patch)
tree58c900fc0907713336e0c699e928e439ac044c63 /clang/CMakeLists.txt
parente3434a862797e74b0b54559366eaaeb137fa2ff7 (diff)
downloadllvm-73593145cb5b6bbb474e2c53153aabdb362731d5.tar.gz
[cmake] do not set execution permission to regular files.
some regular files(e.g. files have no shebang and no execute bit in source dir) are wrongly assigned an execution permission, such as scanview.css and ear.c from libscanbuild, which is unnecessary and introduces warnings in some envs. Reviewed By: MaskRay, phosek Differential Revision: https://reviews.llvm.org/D133308
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 1064cfd0a35a..02ce5de4652d 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -418,7 +418,7 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
endif()
add_custom_target(bash-autocomplete DEPENDS utils/bash-autocomplete.sh)
- install(PROGRAMS utils/bash-autocomplete.sh
+ install(FILES utils/bash-autocomplete.sh
DESTINATION "${CMAKE_INSTALL_DATADIR}/clang"
COMPONENT bash-autocomplete)
if(NOT LLVM_ENABLE_IDE)