summaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorHaowei Wu <haowei@google.com>2023-02-22 16:50:30 -0800
committerHaowei Wu <haowei@google.com>2023-04-24 12:15:44 -0700
commite38cdc5933b026cd25cf70c06f690a431c608d63 (patch)
tree1b28423db4c7853d0b1c02ba1dbbf9a089a373b8 /clang/CMakeLists.txt
parent7b85bfffc486257361a598a3c9d4b6b67e3f6765 (diff)
downloadllvm-e38cdc5933b026cd25cf70c06f690a431c608d63.tar.gz
Disable compiler launcher on external projects and multi stage clang
When using compiler caching program like ccache, there is no point to use them on external projects or multi-stage clang builds. As these builds uses fresh from source code toolchain and will pollute the build cache. If a compiler launcher is still required, a user can explicity define `CMAKE_C_COMPILER_LAUNCHER` and `CMAKE_CXX_COMPILER_LAUNCHER` in `CLANG_BOOTSTRAP_PASSTHROUGH` and `LLVM_EXTERNAL_PROJECT_PASSTHROUGH` flags to enable compiler launcher in these builds. Differential Revision: https://reviews.llvm.org/D144603
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 4508ea4c77aa..fd8558a16f81 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -660,8 +660,6 @@ if (CLANG_ENABLE_BOOTSTRAP)
LLVM_VERSION_SUFFIX
LLVM_BINUTILS_INCDIR
CLANG_REPOSITORY_STRING
- CMAKE_C_COMPILER_LAUNCHER
- CMAKE_CXX_COMPILER_LAUNCHER
CMAKE_MAKE_PROGRAM
CMAKE_OSX_ARCHITECTURES
CMAKE_BUILD_TYPE